summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOlivier Dion <odion@efficios.com>2023-11-01 16:35:16 -0400
committerLudovic Courtès <ludo@gnu.org>2023-11-22 16:51:46 +0100
commit0bc856034076b49cfa20f505a4c11c830b68c1b0 (patch)
tree6d0dd5c451c4d7e4bf13d98faaf4cadcb9678bda /gnu
parentc4b4badb2e5d3b47fb48e765c75a1a0be0ae0217 (diff)
downloadguix-0bc856034076b49cfa20f505a4c11c830b68c1b0.tar.gz
gnu: Add babeltrace/dev.
* gnu/packages/instrumentation.scm (babeltrace/dev): New variable.

Change-Id: Ib54ced9a1ede5d9acc9a53ff325663a28a3b447f
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/instrumentation.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 3097eba033..8b1a2a1c02 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -97,11 +97,9 @@
        (modify-phases %standard-phases
          ;; These are recommended in the project's README for a development
          ;; build configuration.
-         (add-before 'configure 'set-environment-variables
+         (add-after 'unpack 'reconfigure
            (lambda _
-             (setenv "BABELTRACE_DEV_MODE" "1")
-             (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE")
-             (invoke "autoreconf" "-vfi"))))))
+             (delete-file "configure"))))))
     (inputs
      (list glib))
     ;; NOTE - elfutils is used for the LTTng debug information filter
@@ -143,6 +141,21 @@ LTTng and barectf.  This package provides a library with a C API, Python 3
 bindings, and the command-line tool @command{babeltrace2}.")
     (license license:expat)))
 
+(define-public babeltrace/dev
+  (package/inherit babeltrace
+    ;; This dev variant of the package babeltrace is slower but allows better
+    ;; development of plugins as recommended by the authors.
+    (name "babeltrace-dev")
+    (synopsis "Trace manipulation toolkit (variant for plugin developers)")
+    (arguments
+     (substitute-keyword-arguments (package-arguments babeltrace)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-before 'configure 'set-environment-variables
+             (lambda _
+               (setenv "BABELTRACE_DEV_MODE" "1")
+               (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE")))))))))
+
 (define-public barectf
   (package
     (name "barectf")