summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-05-30 23:07:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-05-30 23:09:46 +0200
commit0bcd28e58cb8f06bc6d0e47da22cef3d834a6da7 (patch)
tree2f92b39f286d356f7a54056a2916538aad783e45 /gnu
parentca2516f0653c33494701ad02638bf5d7c5c74f25 (diff)
downloadguix-0bcd28e58cb8f06bc6d0e47da22cef3d834a6da7.tar.gz
gnu: python-scanpy: Update to 1.9.1.
* gnu/packages/bioinformatics.scm (python-scanpy): Update to 1.9.1.
[arguments]: Add phase 'set-numba-cache-dir; disable more broken tests.
[propagated-inputs]: Add python-dask and python-session-info; replace
python-louvain-0.7 with python-louvain.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1d8397c1aa..23c0024e52 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12248,7 +12248,7 @@ implementation differs in these ways:
 (define-public python-scanpy
   (package
     (name "python-scanpy")
-    (version "1.8.2")
+    (version "1.9.1")
     (source
      (origin
        (method git-fetch)
@@ -12258,7 +12258,7 @@ implementation differs in these ways:
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "14zax23lqinv7xyv3491vpl3ydi38naiwaxg5mkfs5zk2406cqdr"))))
+         "0k524xnx3dvpz5yx65p316wghvi01zs17is8w2m3w2qywiswk0sl"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -12278,6 +12278,10 @@ implementation differs in these ways:
                            (invoke "python" "-m" "pip" "install"
                                    wheel (string-append "--prefix=" out)))
                          (find-files "dist" "\\.whl$")))))
+         ;; Numba needs a writable dir to cache functions.
+         (add-before 'check 'set-numba-cache-dir
+           (lambda _
+             (setenv "NUMBA_CACHE_DIR" "/tmp")))
          (replace 'check
            (lambda* (#:key tests? inputs #:allow-other-keys)
              (when tests?
@@ -12285,6 +12289,7 @@ implementation differs in these ways:
                (delete-file-recursively "scanpy/tests/notebooks")
                (delete-file "scanpy/tests/test_clustering.py")
                (delete-file "scanpy/tests/test_datasets.py")
+               (delete-file "scanpy/tests/test_normalization.py")
                (delete-file "scanpy/tests/test_score_genes.py")
                (delete-file "scanpy/tests/test_highly_variable_genes.py")
 
@@ -12293,6 +12298,9 @@ implementation differs in these ways:
                (delete-file "scanpy/tests/test_preprocessing.py")
                (delete-file "scanpy/tests/test_read_10x.py")
 
+               ;; These two fail with "ValueError: I/O operation on closed file."
+               (delete-file "scanpy/tests/test_neighbors_key_added.py")
+
                ;; TODO: these fail with TypingError and "Use of unsupported
                ;; NumPy function 'numpy.split'".
                (delete-file "scanpy/tests/test_metrics.py")
@@ -12318,17 +12326,20 @@ implementation differs in these ways:
                                       " and not test_clustermap"
 
                                       ;; These try to connect to the network
+                                      " and not test_scrublet_plots"
                                       " and not test_plot_rank_genes_groups_gene_symbols"
+                                      " and not test_pca_n_pcs"
                                       " and not test_pca_chunked"
                                       " and not test_pca_sparse"
                                       " and not test_pca_reproducible"))))))))
     (propagated-inputs
      (list python-anndata
+           python-dask
            python-h5py
            python-igraph
            python-joblib
            python-legacy-api-wrap
-           python-louvain-0.7
+           python-louvain
            python-matplotlib
            python-natsort
            python-networkx
@@ -12339,6 +12350,7 @@ implementation differs in these ways:
            python-scikit-learn
            python-scipy
            python-seaborn
+           python-session-info
            python-sinfo
            python-statsmodels
            python-tables