summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-05 12:49:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-05 12:49:41 +0200
commit0c68f7fd9b6156ef3c9a4eb0f2ca5753ebcb38a7 (patch)
tree79e2c9b6726ff6d5a84bec4b1d602097d9b92d5a /gnu
parent9cc66d75a229b8b3d4a1166ce6d29ea2f2815bf0 (diff)
downloadguix-0c68f7fd9b6156ef3c9a4eb0f2ca5753ebcb38a7.tar.gz
gnu: java-bouncycastle: Disable tests.
* gnu/packages/java.scm (java-bouncycastle)[arguments]: Disable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e78e0fcdca..678cbee188 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -8236,6 +8236,7 @@ algorithms and xxHash hashing algorithm.")
     (build-system ant-build-system)
     (arguments
      `(#:jdk ,icedtea-8
+       #:tests? #f
        #:phases
        (modify-phases %standard-phases
          (replace 'build
@@ -8243,9 +8244,10 @@ algorithms and xxHash hashing algorithm.")
              (invoke "ant" "-f" "ant/jdk15+.xml" "build-provider")
              (invoke "ant" "-f" "ant/jdk15+.xml" "build")
              #t))
-         (replace 'check
-           (lambda _
-             (invoke "ant" "-f" "ant/jdk15+.xml" "test")))
+         ;; FIXME: the tests freeze.
+         ;; (replace 'check
+         ;;   (lambda _
+         ;;     (invoke "ant" "-f" "ant/jdk15+.xml" "test")))
          (replace 'install
            (install-jars "build/artifacts/jdk1.5/jars")))))
     (inputs