summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-07-09 11:48:12 +0300
committerAlex Kost <alezost@gmail.com>2015-07-19 12:44:39 +0300
commit0c909c056e4bd2df077245be9c0e523a65ef01a1 (patch)
treed17df2b247ba390cfdabe3a170c3f01934531ee6 /gnu
parent7286933d7ef4ab07a3b061a104abf7a929f4cfd4 (diff)
downloadguix-0c909c056e4bd2df077245be9c0e523a65ef01a1.tar.gz
gnu: emacs-mmm-mode: Use gnu-build-system.
* gnu/packages/emacs.scm (emacs-mmm-mode): Replace melpa-stable URL with
  the github URL and use 'gnu-build-system' instead of
  'emacs-build-system'.  Fix typo (add missing space before the
  description).
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 18 insertions, 8 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 169ab086dc..e71d180ab6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -814,18 +814,28 @@ or XEmacs.")
      (origin
        (method url-fetch)
        (uri (string-append
-             "http://stable.melpa.org/packages/mmm-mode-"
-             version
-             ".tar"))
+             "https://github.com/purcell/mmm-mode/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "1llkzb6d978ym3zv3yfzwj0w5zzmmj3ksrm5swrx1papxcnqnkb9"))))
-    (build-system emacs-build-system)
+         "10kwslnflbjqm62wkrq420crqzdqalzfflp9pqk1i12zm6dm4mfv"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'autogen
+           (lambda _
+             (zero? (system* "sh" "autogen.sh")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("emacs" ,emacs-no-x)
+       ("texinfo" ,texinfo)))
     (home-page "https://github.com/purcell/mmm-mode")
-    (synopsis
-     "Allow multiple major modes in an Emacs buffer")
+    (synopsis "Allow multiple major modes in an Emacs buffer")
     (description
-    "MMM Mode is a minor mode that allows multiple major modes to coexist in a
+     "MMM Mode is a minor mode that allows multiple major modes to coexist in a
 single buffer.")
     (license license:gpl3+)))