summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJake Leporte <jakeleporte@outlook.com>2023-02-10 14:14:27 -0600
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-11 09:22:24 +0100
commit0cd6746a66494264e883748131181bd4a9904788 (patch)
tree8e92d3eb3a9cb75c6e729a613f005e000c9dd0bf /gnu
parent63bf5ba1d82939eab6f2147b964fcd2c60182e24 (diff)
downloadguix-0cd6746a66494264e883748131181bd4a9904788.tar.gz
gnu: Add emacs-ligature.
* gnu/packages/emacs-xyz.scm (emacs-ligature): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8c51d06059..92b466d1de 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4879,6 +4879,32 @@ them whenever another command is invoked.")
 a command.")
     (license license:gpl3+)))
 
+(define-public emacs-ligature
+  (let ((commit "3d1460470736777fd8329e4bb4ac359bf4f1460a")
+        (revision "1"))
+    (package
+      (name "emacs-ligature")
+      (version (git-version "1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/mickeynp/ligature.el")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1rnx2mp8y1phnvfirmf4a6lza38dg2554r9igyijl9rgqpjax94d"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/mickeynp/ligature.el")
+      (synopsis "Typographic ligatures in Emacs")
+      (description
+       "This package maps ordinary graphemes (characters) to fancy
+ligatures, if both your version of Emacs and the font supports it.  With this
+package you can control where Emacs must display ligatures. That is useful if
+you only want a subset of the ligatures in certain major modes, for instance,
+or if you want to ensure that some modes have no ligatures at all.")
+      (license license:gpl3+))))
+
 (define-public emacs-olivetti
   (package
     (name "emacs-olivetti")