summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDhruvin Gandhi <contact@dhruvin.dev>2021-07-03 10:02:17 +0530
committerLudovic Courtès <ludo@gnu.org>2021-07-31 01:03:24 +0200
commit0e9b77d8d08e0270f372f122a6e26d2a95c249c0 (patch)
tree23246ca0252a22ecff24556a35cb6481d1a7a46a /gnu
parent630c39d8df7557b6a0941c1d5ee879e487de0f5e (diff)
downloadguix-0e9b77d8d08e0270f372f122a6e26d2a95c249c0.tar.gz
gnu: python-yubikey-manager: Fix libykpers reference.
* gnu/packages/security-token.scm (python-yubikey-manager): Fix libykpers reference.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/security-token.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index f8c9661df1..1f60e25458 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2020 Raphaël Mélotte <raphael.melotte@mind.be>
 ;;; Copyright © 2021 Antero Mejr <antero@kodmin.com>
 ;;; Copyright © 2021 Sergey Trofimov <sarg@sarg.org.ru>
+;;; Copyright © 2021 Dhruvin Gandhi <contact@dhruvin.dev>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -657,6 +658,23 @@ implementing a Relying Party.")
                (base32
                 "11rsmcaj60k3y5m5gdhr2nbbz0w5dm3m04klyxz0fh5hnpcmr7fm"))))
     (build-system python-build-system)
+    (arguments
+     '(#:modules ((srfi srfi-1)
+                  (guix build utils)
+                  (guix build python-build-system))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-libykpers-reference
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "ykman/driver_otp.py"
+               (("Ykpers\\('ykpers-1', '1'\\)")
+                (string-append
+                 "Ykpers('"
+                 (find (negate symbolic-link?)
+                       (find-files (assoc-ref inputs "yubikey-personalization")
+                                   "^libykpers-.*\\.so\\..*"))
+                 "')")))
+             #t)))))
     (propagated-inputs
      `(("python-six" ,python-six)
        ("python-pyscard" ,python-pyscard)