summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSuhail Singh <suhailsingh247@gmail.com>2024-03-05 19:50:38 -0500
committerAndrew Tropin <andrew@trop.in>2024-03-07 13:36:23 +0300
commit0f2eede9f1d4574813935b7f58384036d509002d (patch)
tree0767e1f4defec6f196690680ca26414f90d64b89 /gnu
parent915e2fc339db7b52beccb9e43fb888899ed8306b (diff)
downloadguix-0f2eede9f1d4574813935b7f58384036d509002d.tar.gz
gnu: emacs-ox-tufte: Simplify test invocation.
* gnu/packages/emacs-xyz.scm (emacs-ox-tufte): Simplify the test invocation
using the --use-emacsloadpath option in emacs-eldev@1.9.

Change-Id: Ie61a336251b2670872cc8d049cc1c62284b7f350
Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 903537acb5..7fa5df9202 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33691,22 +33691,7 @@ simple but powerful Org contents.")
      (list
       #:include #~(cons "^src/" %default-include)
       #:tests? #t
-      ;; <https://github.com/emacs-eldev/eldev/issues/99#issuecomment-1912637609>
-      #:test-command #~(list "eldev" "-X" "-dtTC" "test")
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-after 'unpack 'configure-eldev
-            (lambda _
-              (setenv "HOME"
-                      (string-append (getcwd) "/.eldev"))
-              (with-output-to-file "Eldev-local"
-                (lambda _
-                  (format #t "~s"
-                          '(dolist (d (split-string (getenv
-                                                     "EMACSLOADPATH")
-                                                    ":" t))
-                                   (ignore-errors
-                                    (eldev-use-local-dependency d)))))))))))
+      #:test-command #~(list "eldev" "--use-emacsloadpath" "-dtTC" "test")))
     (native-inputs (list emacs-buttercup emacs-eldev))
     (propagated-inputs (list emacs-org))
     (home-page "https://github.com/ox-tufte/ox-tufte")