summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:48:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-14 20:15:27 +0200
commit10bcd4bb956c09dd13d9296b12c0ee382175976a (patch)
tree22735dd42146488f1eb3c48964ace5b21e2f91b2 /gnu
parentd5752f68ef38ce779723cf5864574374b8417ff3 (diff)
downloadguix-10bcd4bb956c09dd13d9296b12c0ee382175976a.tar.gz
gnu: mupen64plus-core: Don't use unstable tarball.
* gnu/packages/emulators.scm (mupen64plus-core)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emulators.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 24f8691000..a22bc49bac 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -466,13 +466,13 @@ and Game Boy Color games.")
     (version "2.5")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/mupen64plus/mupen64plus-core/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mupen64plus/mupen64plus-core.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0dg2hksm5qni2hcha93k7n4fqr92888p946f7phb0ndschzfh9kk"))))
+        (base32 "116fndl6652zrp1r6ag4xv3dzp1x52mlvadj8xwflq07fd5rhri1"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)