summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-16 16:34:41 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:18 +0800
commit10c11d2b6d8a2ed97acc7149cc4d71537c579253 (patch)
tree03cd8b0ace88494d739ec9feb1166ba22c6ba55d /gnu
parentc196c4c3536389094c3a2fc5b9bd62e63fd02689 (diff)
downloadguix-10c11d2b6d8a2ed97acc7149cc4d71537c579253.tar.gz
gnu: Add python-django-configurations.
* gnu/packages/django.scm (python-django-configurations): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index b6f695b080..ca696abf19 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -209,6 +209,46 @@ to the @dfn{don't repeat yourself} (DRY) principle.")
 with a @var{CACHE_URL} environment variable.")
     (license license:expat)))
 
+(define-public python-django-configurations
+  (package
+    (name "python-django-configurations")
+    (version "2.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "django-configurations" version))
+              (sha256
+               (base32
+                "11chll26iqqy5chyx62hya20cadk10nm2la7sch7pril70a5rhm6"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     ;; Taken from tox.ini.
+                     (setenv "DJANGO_SETTINGS_MODULE" "tests.settings.main")
+                     (setenv "DJANGO_CONFIGURATION" "Test")
+                     (setenv "PYTHONPATH"
+                             (string-append ".:" (getenv "GUIX_PYTHONPATH")))
+                     (invoke "django-cadmin" "test" "-v2")))))))
+    (propagated-inputs
+     (list python-django))
+    (native-inputs
+     (list python-dj-database-url
+           python-dj-email-url
+           python-dj-search-url
+           python-django-cache-url
+           python-setuptools-scm))
+    (home-page "https://django-configurations.readthedocs.io/")
+    (synopsis "Helper module for organizing Django settings")
+    (description
+     "@code{django-configurations} helps you organize the configuration of
+your Django project by providing glue code to bridge between Django'smodule
+based settings system and programming patterns like mixins, facades, factories
+and adapters that are useful for non-trivial configuration scenarios.")
+    (license license:bsd-3)))
+
 (define-public python-django-extensions
   (package
     (name "python-django-extensions")