summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 03:19:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-24 04:36:51 +0200
commit110888f85f21df6922d4042926d25c567fa0d966 (patch)
treeacec77cb2186caca5198c44fd7408658ea0c3458 /gnu
parent8ee3e4d9e9cd991ece0cb591ff10c223aa154866 (diff)
downloadguix-110888f85f21df6922d4042926d25c567fa0d966.tar.gz
gnu: electron-cash: Return #t from phases.
* gnu/packages/finance.scm (electron-cash)[arguments]: Return truth from
all phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3f58999e4b..6ffdff5d6e 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -509,7 +509,7 @@ other machines/servers.  Electrum does not download the Bitcoin blockchain.")
        ("qtsvg" ,qtsvg)
        ("zlib" ,zlib)))
     (arguments
-     `(#:tests? #f ; No tests
+     `(#:tests? #f                      ; no tests
        #:modules ((guix build python-build-system)
                   (guix build qt-utils)
                   (guix build utils))
@@ -521,12 +521,14 @@ other machines/servers.  Electrum does not download the Bitcoin blockchain.")
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* "setup.py"
                (("~/.local/share")
-                (string-append (assoc-ref outputs "out") "/local/share")))))
+                (string-append (assoc-ref outputs "out") "/local/share")))
+             #t))
          (add-after 'unpack 'use-libsecp256k1-input
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "lib/secp256k1.py"
                (("library_paths = .* 'libsecp256k1.so.0'.")
-                (string-append "library_paths = ('" (assoc-ref inputs "libsecp256k1") "/lib/libsecp256k1.so.0'")))))
+                (string-append "library_paths = ('" (assoc-ref inputs "libsecp256k1") "/lib/libsecp256k1.so.0'")))
+             #t))
          (add-after 'install 'wrap-qt
            (lambda* (#:key outputs #:allow-other-keys)
              (wrap-qt-program (assoc-ref outputs "out") "electron-cash")