summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-08-31 10:08:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-09-20 11:37:36 +0200
commit127b04d74119f30da763cf035949941dc25015b2 (patch)
tree697618afe811e21622864e811e9d91928370733f /gnu
parent7d1b5022e959dcfc2bb0bd6a6507be3706b3f48a (diff)
downloadguix-127b04d74119f30da763cf035949941dc25015b2.tar.gz
gnu: lilypond: Update to 2.19.27.
* gnu/packages/music.scm (lilypond): Update to 2.19.27.
  [inputs]: Add font-tex-gyre.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 05a490574b..78310edf0e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -187,7 +187,7 @@ you to define complex tempo maps for entire songs or performances.")
 (define-public lilypond
   (package
     (name "lilypond")
-    (version "2.18.2")
+    (version "2.19.27")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -196,14 +196,15 @@ you to define complex tempo maps for entire songs or performances.")
                     name "-" version ".tar.gz"))
               (sha256
                (base32
-                "01xs9x2wjj7w9appaaqdhk15r1xvvdbz9qwahzhppfmhclvp779j"))))
+                "11v4jr4qj1jpqvjw1ww7riv8pxfyasif8mf16l447f1xq1ifhkhs"))))
     (build-system gnu-build-system)
     (arguments
-     `(;; Tests fail with this error:
-       ;; Undefined subroutine &main::get_index called at
-       ;; ./lilypond-2.18.2/Documentation/lilypond-texi2html.init line 2127.
-       #:tests? #f
+     `(#:tests? #f ; out-test/collated-files.html fails
        #:out-of-source? #t
+       #:configure-flags
+       (list (string-append "--with-texgyre-dir="
+                            (assoc-ref %build-inputs "font-tex-gyre")
+                            "/share/fonts/opentype/"))
        #:phases
        (alist-cons-before
         'configure 'prepare-configuration
@@ -216,6 +217,7 @@ you to define complex tempo maps for entire songs or performances.")
     (inputs
      `(("guile" ,guile-1.8)
        ("font-dejavu" ,font-dejavu)
+       ("font-tex-gyre" ,font-tex-gyre)
        ("fontconfig" ,fontconfig)
        ("freetype" ,freetype)
        ("ghostscript" ,ghostscript)