summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-09 20:48:46 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:19 +0800
commit12af75086852d0aa0e9b2f925cd095e26ac96f5c (patch)
tree26ed82921f244d6aeb76d4bd68c12f3824753520 /gnu
parentb9142073c429f5ea37b7ff07830ff9275597710e (diff)
downloadguix-12af75086852d0aa0e9b2f925cd095e26ac96f5c.tar.gz
gnu: graphite-web: Update to 1.1.10.
* gnu/packages/monitoring.scm (graphite-web): Update to 1.1.10.
[arguments]: Relax Django requirement.
[propagated-inputs]: Remove PYTHON-WHISPER , PYTHON-SCANDIR, and
PYTHON-TXAMPQ.  Replace PYTHON-DJANGO-2.2 with PYTHON-DJANGO-3.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/monitoring.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 3238f11fb4..e77ae19194 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -454,14 +454,14 @@ and persisting them to disk using the Whisper time-series library.")
 (define-public graphite-web
   (package
     (name "graphite-web")
-    (version "1.1.7")
+    (version "1.1.10")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "graphite-web" version))
        (sha256
         (base32
-         "1l5a5rry9cakqxamvlx4xq63jifmncb6815bg9vy7fg1zyd3pjxk"))))
+         "0nnk3kwn0b6bq9xnmv9bac6hpcbdgpgwf283c1ck5nm80panh61z"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f               ;XXX: not in PyPI release & requires database
@@ -471,22 +471,20 @@ and persisting them to disk using the Whisper time-series library.")
            (lambda _
              (substitute* "setup.py"
                ;; Allow newer versions of django-tagging.
-               (("django-tagging==")
-                "django-tagging>="))
-             #t))
+               (("django-tagging==") "django-tagging>=")
+               ;; And Django.
+               (("Django>=1\\.8,<3\\.1") "Django>=1.8,<4"))))
          ;; Don't install to /opt
          (add-after 'unpack 'do-not-install-to-/opt
            (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
     (propagated-inputs
      (list python-cairocffi
-           python-pytz
-           python-whisper
-           python-django-2.2
+           python-django-3.2
            python-django-tagging
-           python-scandir
-           python-urllib3
            python-pyparsing
-           python-txamqp))
+           python-pytz
+           python-six
+           python-urllib3))
     (home-page "https://graphiteapp.org/")
     (synopsis "Scalable realtime graphing system")
     (description "Graphite is a scalable real-time graphing system that does