summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-01-26 01:13:18 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 09:36:57 +0100
commit12c72ab2cccf2619de2ebbd18129d069af75d941 (patch)
tree8f998943f3140a2bdc5260c013b423484ac53507 /gnu
parent3da36f50a1284d75e1e575441b6d19d8cd5235a1 (diff)
downloadguix-12c72ab2cccf2619de2ebbd18129d069af75d941.tar.gz
gnu: go-github-com-golang-protobuf-proto: Update to 1.5.3.
* gnu/packages/golang.scm (go-github-com-golang-protobuf-proto): Update to
1.5.3.
[arguments]: Enable tests.
[propagated-inputs]: Add go-google-golang-org-protobuf.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8705f47c6d..e453a51fb2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6232,7 +6232,7 @@ test results.")
 (define-public go-github-com-golang-protobuf-proto
   (package
     (name "go-github-com-golang-protobuf-proto")
-    (version "1.3.1")
+    (version "1.5.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -6241,13 +6241,13 @@ test results.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "15am4s4646qy6iv0g3kkqq52rzykqjhm4bf08dk0fy2r58knpsyl"))))
+                "03f1w2cd4s8a3xhl61x7yjx81kbzlrjpvnnwmbhqnz814yi7h43i"))))
     (build-system go-build-system)
     (arguments
      '(#:import-path "github.com/golang/protobuf/proto"
-       #:unpack-path "github.com/golang/protobuf"
-       ;; Requires unpackaged golang.org/x/sync/errgroup
-       #:tests? #f))
+       #:unpack-path "github.com/golang/protobuf"))
+    (propagated-inputs
+     (list go-google-golang-org-protobuf))
     (synopsis "Go support for Protocol Buffers")
     (description "This package provides Go support for the Protocol Buffers
 data serialization format.")