summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 17:23:32 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:33:15 +0000
commit13188641f3a3f104e1c73700b8bfa99121643e27 (patch)
tree29b1b213efea2b50b4866a196f1f65d43517e1c8 /gnu
parent2175660d921364c91a9a0fedc2edce1d820c705f (diff)
downloadguix-13188641f3a3f104e1c73700b8bfa99121643e27.tar.gz
gnu: go-golang-org-x-sync: Move to golang-build.
* gnu/packages/golang.scm (go-golang-org-x-sync): Move from here ...
* gnu/packages/golang-build.scm: ... to here.

Change-Id: I28b72dc45116398512c0255ac9e06b9c539e9e7b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-build.scm30
-rw-r--r--gnu/packages/golang.scm30
2 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 8e64571929..7b8653960d 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
+;;; Copyright © 2020 HiPhish <hiphish@posteo.de>
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Vagrant Cascadian <vagrant@debian.org>
@@ -168,6 +169,35 @@ loading algorithms.")
     (description
      "This package provides an HTML5-compliant tokenizer and parser.")))
 
+(define-public go-golang-org-x-sync
+  (let ((commit "8fcdb60fdcc0539c5e357b2308249e4e752147f1")
+        (revision "1"))
+    (package
+      (name "go-golang-org-x-sync")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://go.googlesource.com/sync")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "07qrhni6f5hh5p95k1yk6s4wsj341q663irvx6rllrxfsymj6a0z"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "golang.org/x/sync"
+         #:tests? #f
+         ;; Source-only package
+         #:phases (modify-phases %standard-phases
+                    (delete 'build))))
+      (home-page "https://go.googlesource.com/sync/")
+      (synopsis "Additional Go concurrency primitives")
+      (description "This package provides Go concurrency primitives in
+addition to the ones provided by the language and “sync” and “sync/atomic”
+packages.")
+      (license license:bsd-3))))
+
 (define-public go-golang.org-x-sync-errgroup
   (let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
         (revision "0"))
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 33cc030894..711a762a29 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3559,36 +3559,6 @@ editor.")
 processing.")
       (license license:bsd-3))))
 
-(define-public go-golang-org-x-sync
-  (let ((commit "8fcdb60fdcc0539c5e357b2308249e4e752147f1")
-        (revision "1"))
-    (package
-      (name "go-golang-org-x-sync")
-      (version (git-version "0.1.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://go.googlesource.com/sync")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "07qrhni6f5hh5p95k1yk6s4wsj341q663irvx6rllrxfsymj6a0z"))))
-      (build-system go-build-system)
-      (arguments
-       `(#:import-path "golang.org/x/sync"
-         #:tests? #f
-         ;; Source-only package
-         #:phases (modify-phases %standard-phases
-                    (delete 'build))))
-      (synopsis "Additional Go concurrency primitives")
-      (description
-       "This package provides Go concurrency primitives in addition
-to the ones provided by the language and “sync” and “sync/atomic”
-packages.")
-      (home-page "https://go.googlesource.com/sync/")
-      (license license:bsd-3))))
-
 (define-public go-golang-org-x-text
   (package
     (name "go-golang-org-x-text")