summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:35:35 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:24 -0500
commit1371b119f3678e592c6aa03648df8bcd902dfeed (patch)
tree06c6f0fa83cf3d0499922bb62eed16b6623a1a33 /gnu
parent65b1156d2b92bebacef1792615c85140c5ce41a3 (diff)
downloadguix-1371b119f3678e592c6aa03648df8bcd902dfeed.tar.gz
gnu: go-github-com-xeipuuv-gojsonschema: Adjust inputs.
* gnu/packages/golang-web.scm (go-github-com-xeipuuv-gojsonschema):
[propagated-inputs]: Move go-github-com-stretchr-testify from here ...
[native-inputs]: ... to here.

Change-Id: Id865d5821060cd847aeb9ccfc7b7a477e12f7b7b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c97dfa7757..346ca87cc7 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1232,10 +1232,11 @@ replacement for native @code{net/http} module.")
                     (string-append "// " all))
                    (("\\{\"phase\": \"invalid definition" all)
                     (string-append "// " all)))))))))
+      (native-inputs
+       (list go-github-com-stretchr-testify))
       (propagated-inputs
        (list go-github-com-xeipuuv-gojsonreference
-             go-github-com-xeipuuv-gojsonpointer
-             go-github-com-stretchr-testify))
+             go-github-com-xeipuuv-gojsonpointer))
       (home-page "https://github.com/xeipuuv/gojsonschema")
       (synopsis "Implementation of JSON Schema for Go")
       (description