summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-02-18 11:23:16 -0500
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-02-18 21:16:06 +0100
commit13de68587730aa812926256b3269ada315944b99 (patch)
treea29874a0d5d9de227444715f0045d3b400328a7b /gnu
parent690aa1c59db1ba08bc79fcaf1e948c4cd821c1be (diff)
downloadguix-13de68587730aa812926256b3269ada315944b99.tar.gz
gnu: webrtc-for-telegram-desktop: Adjust native inputs.
This fixes a segmentation fault in telegram-desktop.

* gnu/packages/telegram.scm (webrtc-for-telegram-desktop) [native-inputs]:
Add gcc-9 and perl.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/telegram.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index 2430242241..daff57a544 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -126,7 +126,9 @@
                   (copy-recursively libyuv-from libyuv-to))
                 #t)))))
        (native-inputs
-        `(("pkg-config" ,pkg-config)
+        `(("gcc" ,gcc-9) ; keep in line with telegram-desktop
+          ("perl" ,perl)
+          ("pkg-config" ,pkg-config)
           ("python" ,python-wrapper)
           ("yasm" ,yasm)))
        (inputs