summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-06-23 13:48:46 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 09:44:15 +0200
commit143ecd555a15164efc2bacda09598633e041b8a8 (patch)
tree2e871ce09602fd4caf440010afeea17c142c263d /gnu
parent828f75ce75a013b56b51910b9acae02492c015a2 (diff)
downloadguix-143ecd555a15164efc2bacda09598633e041b8a8.tar.gz
gnu: Add r-smoof.
* gnu/packages/cran.scm (r-smoof): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 28c1126e0d..b1eeb1ef53 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8162,6 +8162,33 @@ University Press.  It provides smoothing methods for nonparametric regression
 and density estimation")
     (license license:gpl2+)))
 
+(define-public r-smoof
+  (package
+    (name "r-smoof")
+    (version "1.6.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "smoof" version))
+              (sha256
+               (base32
+                "1cazhnd0m5jjzixaqgqh2h3rsa2sw3k8slj5cmgm8v47aaqn91mg"))))
+    (properties `((upstream-name . "smoof")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-bbmisc
+                             r-checkmate
+                             r-ggplot2
+                             r-paramhelpers
+                             r-rcpp
+                             r-rcpparmadillo))
+    (home-page "https://jakobbossek.github.io/smoof/")
+    (synopsis "Single and multi-objective optimization test functions")
+    (description
+     "This tool generates high number of both single- and multi-objective test
+functions.  These functions are frequently used for the benchmarking of
+(numerical) optimization algorithms.  Moreover, it offers a set of convenient
+functions to generate, plot and work with objective functions.")
+    (license license:bsd-2)))
+
 (define-public r-smurf
   (package
     (name "r-smurf")