summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2024-01-29 15:21:42 -0800
committerClément Lassieur <clement@lassieur.org>2024-01-30 00:40:15 +0100
commit144c95032e517bb8ce466b930fe91506bcc92b2b (patch)
treef3dc9374f8f80abd89c95d08534911a72605e176 /gnu
parentcdadef64093fc12fd335a2b7b54d4b05c829107e (diff)
downloadguix-144c95032e517bb8ce466b930fe91506bcc92b2b.tar.gz
gnu: emacspeak: Update to 59.0.
* gnu/packages/emacs-xyz.scm (emacspeak): Update to 59.0.
[source]: Switch to git-fetch.

Change-Id: I80e93286fa0de931e85f07c22e050faeaf8d0280
Signed-off-by: Clément Lassieur <clement@lassieur.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 171defcdb5..4514bd1b25 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -18367,15 +18367,16 @@ highlights quasi-quoted expressions.")
 (define-public emacspeak
   (package
     (name "emacspeak")
-    (version "53.0")
+    (version "59.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/tvraman/emacspeak/releases/download/"
-             version "/emacspeak-" version ".tar.bz2"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tvraman/emacspeak")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "0lasj4ggsh93ingf46n16wxfx5zzxvr1igikbmdqlz3i99j331gs"))))
+        (base32 "010c8hy8nmffaqn1h8n8hmyxvn7gx6ygx4pxgdfp1vl8bb1bz54y"))))
     (build-system gnu-build-system)
     (arguments
      (list