summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-01 21:09:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-01 21:09:23 -0400
commit15916cf40033023b035e7b6a0ad91d39520a2e6a (patch)
tree5136fc7aa95130d9bc199e9f2798e906a7ebcbff /gnu
parent70dbdbe39b8b3aa4d6c6fe4919568e6f68f721e2 (diff)
downloadguix-15916cf40033023b035e7b6a0ad91d39520a2e6a.tar.gz
gnu: python-sphinx: Update to 4.2.0.
* gnu/packages/sphinx.scm (python-sphinx): Update to 4.2.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/sphinx.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 8e7b67fd0d..5fd63a617c 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -17,6 +17,7 @@
 ;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -56,26 +57,27 @@
 (define-public python-sphinx
   (package
     (name "python-sphinx")
-    (version "3.5.2")
+    (version "4.2.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Sphinx" version))
        (sha256
         (base32
-         "1zx5ik3rqbawyz52lidljqkdgv2418cwnl67jxf26sbb9g1gqb37"))))
+         "19jq21py7m061v8142y2dbqrbv0adqcdjmharrdy34a432wqs1wl"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             ;; Requires Internet access.
-             (delete-file "tests/test_build_linkcheck.py")
-             (substitute* "tests/test_build_latex.py"
-               (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
-                "@pytest.mark.skip()"))
-             (invoke "make" "test"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Requires Internet access.
+               (delete-file "tests/test_build_linkcheck.py")
+               (substitute* "tests/test_build_latex.py"
+                 (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
+                  "@pytest.mark.skip()"))
+               (invoke "make" "test")))))))
     (propagated-inputs
      `(("python-babel" ,python-babel)
        ("python-docutils" ,python-docutils)