summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-27 21:59:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-27 22:02:01 +0200
commit15ff38f1b4ca129168502d05337810acaea10f36 (patch)
tree30ff4afe6e1a89a9df3e1728fa4290ff888ff802 /gnu
parent8960b2e64d4657e4c520da8ff85d9eb8b12a10b6 (diff)
downloadguix-15ff38f1b4ca129168502d05337810acaea10f36.tar.gz
gnu: dovecot: Update to 2.3.1.
* gnu/packages/mail.scm (dovecot): Update to 2.3.1.
[arguments]: Rename ‘patch-other-shebangs’ phase to the more accurate
‘patch-other-file-names’... then patch more file names.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 16705b6afd..4574976a2b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1180,7 +1180,7 @@ facilities for checking incoming mail.")
 (define-public dovecot
   (package
     (name "dovecot")
-    (version "2.3.0.1")
+    (version "2.3.1")
     (source
      (origin
        (method url-fetch)
@@ -1188,7 +1188,7 @@ facilities for checking incoming mail.")
                            (version-major+minor version) "/"
                            name "-" version ".tar.gz"))
        (sha256 (base32
-                "0lzisrdgrj5qqwjb7bv99mf2aljm568r6g108yisp0s644z2nxxb"))))
+                "14zva4f8k64x86sm9n21cp2yvrpph6k6k52bm22a00pxjwdq50q8"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -1205,20 +1205,23 @@ facilities for checking incoming mail.")
                   (add-before
                    'configure 'pre-configure
                    (lambda _
-                     ;; Simple hack to avoid installing in /etc
+                     ;; Simple hack to avoid installing in /etc.
                      (substitute* '("doc/Makefile.in"
                                     "doc/example-config/Makefile.in")
                        (("pkgsysconfdir = .*")
                         "pkgsysconfdir = /tmp/etc"))
                      #t))
                   (add-after
-                   'unpack 'patch-other-shebangs
+                   'unpack 'patch-other-file-names
                    (lambda _
                      (substitute*
-                       "src/lib-program-client/test-program-client-local.c"
+                         "src/lib-program-client/test-program-client-local.c"
+                       (("(/bin/| )cat") (which "cat"))
                        (("/bin/echo") (which "echo"))
-                       (("/bin/cat") (which "cat"))
-                       (("/bin/false") (which "false")))
+                       (("/bin/false") (which "false"))
+                       (("/bin/sh") (which "bash"))
+                       (("head") (which "head"))
+                       (("sleep") (which "sleep")))
                      #t)))))
     (home-page "https://www.dovecot.org")
     (synopsis "Secure POP3/IMAP server")