summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-01-13 17:16:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-01-14 11:41:21 +0200
commit161091f0537b4fc86fc606f73970b25ed52fee14 (patch)
tree25add691c3e591bf997351ed49065aa3e678e1d1 /gnu
parent12bccb8e3b08ecb44da89f0b54dd183169ccff73 (diff)
downloadguix-161091f0537b4fc86fc606f73970b25ed52fee14.tar.gz
gnu: aria2: Update to 1.36.0.
* gnu/packages/bittorrent.scm (aria2): Update to 1.36.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bittorrent.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 7716bcc88b..3f4aaeebb9 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -297,7 +297,7 @@ maintained upstream.")
 (define-public aria2
   (package
     (name "aria2")
-    (version "1.35.0")
+    (version "1.36.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/aria2/aria2/releases/"
@@ -305,7 +305,7 @@ maintained upstream.")
                                   "/aria2-" version ".tar.xz"))
               (sha256
                (base32
-                "1zbxc517d97lb96f15xcy4l7b66grxrp3h2ids2jiwkaip87yaqy"))))
+                "1987x4ywnnrhhfs9hi2h820c200d7nas9nd35414yh0jiihfglaq"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list "--enable-libaria2"
@@ -320,8 +320,7 @@ maintained upstream.")
                 (string-append "// " text)))
              (substitute* "test/LpdMessageReceiverTest.cc"
                (("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageReceiverTest\\);" text)
-                (string-append "// " text)))
-             #t)))))
+                (string-append "// " text))))))))
     (native-inputs
      (list cppunit ; for the tests
            pkg-config))