summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-20 13:46:48 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-20 14:22:37 -0500
commit1699b2d969806e7388ab5a00354b7938a7887757 (patch)
tree346047d687bd2e8ae89e426cba52e3d6383d9069 /gnu
parent2362b3e0d9d8936330a9dfe3bf416e4e74d07270 (diff)
downloadguix-1699b2d969806e7388ab5a00354b7938a7887757.tar.gz
gnu: Add JSON-XS.
* gnu/packages/perl.scm (perl-json-xs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 877900b996..742a123854 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1874,6 +1874,28 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
 allowing data to be efficiently communicated between processes.")
     (license (package-license perl))))
 
+(define-public perl-json-xs
+  (package
+    (name "perl-json-xs")
+    (version "3.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/"
+                           "JSON-XS-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1aviik480m61ykwvyix83grywzbk828wvfz19hqfvaasd8jz73af"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-common-sense" ,perl-common-sense)
+       ("perl-types-serialiser" ,perl-types-serialiser)))
+    (home-page "http://search.cpan.org/dist/JSON-XS")
+    (synopsis "JSON serialising/deserialising for Perl")
+    (description "This module converts Perl data structures to JSON and vice
+versa.")
+    (license (package-license perl))))
+
 (define-public perl-list-moreutils
   (package
     (name "perl-list-moreutils")