summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-11 11:40:52 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-11 11:40:52 +0200
commit16a7a7456109bd5be45081ba2d78bf19ba1f0c3c (patch)
tree7ae2cdb8b305d4a56f878d39ad406ea3fa86bd61 /gnu
parentaa5c206348b5606cc82bb1436aca5c9675332993 (diff)
downloadguix-16a7a7456109bd5be45081ba2d78bf19ba1f0c3c.tar.gz
Revert "gnu: libinput: Update to 1.9.3."
This reverts commit 5f5083749c1ff2731e84fa7d8eea182ad45c18a5.

Ninja FTBFS on armhf-linux and thus cannot build libinput.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm23
1 files changed, 7 insertions, 16 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6b5dfe8ea7..6a4e118f76 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -33,7 +33,6 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
-  #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
   #:use-module (gnu packages acl)
@@ -68,7 +67,6 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages python)
-  #:use-module (gnu packages valgrind)
   #:use-module (gnu packages w3m)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xml)
@@ -143,22 +141,19 @@ freedesktop.org project.")
 (define-public libinput
   (package
     (name "libinput")
-    (version "1.9.3")
+    (version "1.7.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://freedesktop.org/software/libinput/"
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "09wkc5qqk1k2a68cwfy4x853z8z35wf2qkijh66kacsvc2fjq394"))))
-    (build-system meson-build-system)
-    (arguments '(#:configure-flags '("-Ddocumentation=false")))
+                "07fbzxddvhjcch43hdxb24sj7ri96zzpcjalvsicmw0i4wnn2v89"))))
+    (build-system gnu-build-system)
     (native-inputs
      `(("cairo" ,cairo)
-       ("check" ,check)
        ("gtk+" ,gtk+)
-       ("pkg-config" ,pkg-config)
-       ("valgrind" ,valgrind)))
+       ("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("libudev" ,eudev))) ; required by libinput.pc
     (inputs
@@ -177,17 +172,13 @@ other applications that need to directly deal with input devices.")
   (package (inherit libinput)
     (name "libinput-minimal")
     (native-inputs
-     `(("check" ,check)
-       ("pkg-config" ,pkg-config)
-       ("valgrind" ,valgrind)))
+     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("libevdev" ,libevdev)
        ("mtdev" ,mtdev)))
     (arguments
-     '(#:configure-flags
-       '("-Dlibwacom=false"
-         "-Ddocumentation=false"
-         "-Ddebug-gui=false"))))) ; requires gtk+@3
+      `(#:configure-flags
+        '("--disable-libwacom")))))
 
 (define-public libxdg-basedir
   (package