summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-16 12:47:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-16 12:49:05 +0300
commit16dcf12736448d219c5a7246a75c0bfcbb302cbe (patch)
treecce1d1ee0c5110a6fd5782520b0da889cbc8e074 /gnu
parent6675cd8c2408e8eecf652950da2b1a13df66c6d6 (diff)
downloadguix-16dcf12736448d219c5a7246a75c0bfcbb302cbe.tar.gz
gnu: Add rust-lexical-core-0.7.
* gnu/packages/crates-io.scm (rust-lexical-core-0.7): New variable.
(rust-lexical-core-0.4): Inherit from rust-lexical-core-0.7.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm45
1 files changed, 36 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c7145c84ee..2f81d35d88 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -11178,8 +11178,43 @@ requires non-const function calls to be computed.")
      "This package provides a library providing a lazily filled Cell struct.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-lexical-core-0.7
+  (package
+    (name "rust-lexical-core")
+    (version "0.7.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "lexical-core" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "05i6b69ay8xbxw88vx89vglb7xm5n8ky82hax7d5a7z60bdccrfv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-arrayvec" ,rust-arrayvec-0.5)
+        ("rust-bitflags" ,rust-bitflags-1)
+        ("rust-cfg-if" ,rust-cfg-if-0.1)
+        ("rust-dtoa" ,rust-dtoa-0.4)
+        ("rust-ryu" ,rust-ryu-1.0)
+        ("rust-static-assertions" ,rust-static-assertions-1))
+       #:cargo-development-inputs
+       (("rust-approx" ,rust-approx-0.3)
+        ("rust-proptest" ,rust-proptest-0.9)
+        ("rust-quickcheck" ,rust-quickcheck-0.9))))
+    (home-page
+     "https://github.com/Alexhuszagh/rust-lexical/tree/master/lexical-core")
+    (synopsis
+     "Lexical, to- and from-string conversion routines")
+    (description
+     "Lexical, to- and from-string conversion routines.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-lexical-core-0.4
   (package
+    (inherit rust-lexical-core-0.7)
     (name "rust-lexical-core")
     (version "0.4.2")
     (source
@@ -11191,7 +11226,6 @@ requires non-const function calls to be computed.")
        (sha256
         (base32
          "1gr5y3ykghd3wjc00l3iizkj1dxylyhwi6fj6yn2qg06nzx771iz"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
@@ -11204,14 +11238,7 @@ requires non-const function calls to be computed.")
        (("rust-approx" ,rust-approx-0.3)
         ("rust-proptest" ,rust-proptest-0.9)
         ("rust-quickcheck" ,rust-quickcheck-0.8)
-        ("rust-rustc-version" ,rust-rustc-version-0.2))))
-    (home-page
-     "https://github.com/Alexhuszagh/rust-lexical/tree/master/lexical-core")
-    (synopsis
-     "Lexical, to- and from-string conversion routines")
-    (description
-     "Lexical, to- and from-string conversion routines.")
-    (license (list license:asl2.0 license:expat))))
+        ("rust-rustc-version" ,rust-rustc-version-0.2))))))
 
 (define-public rust-libc-0.2
   (package