summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-12-18 13:42:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-12 21:42:07 +0000
commit171dbdcb75170ea3ce1e7b081cd2d55aea686c46 (patch)
treed1b8c34bf129c3604125faac7c7350b807db972c /gnu
parent1f38e64779fa865bf25924a718950ea2720cd318 (diff)
downloadguix-171dbdcb75170ea3ce1e7b081cd2d55aea686c46.tar.gz
gnu: python-stsci-imagestats: Enable tests
* gnu/packages/astronomy.scm (python-stsci-imagestats): Enable tests.
[arguments]<#:phases>: Add 'build-extensions phase.
[native-inputs]: Add python-pytest.

Change-Id: I8cb35fd083453d577eb6ad94f097502566c1bcee
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 00653efd70..1e4d54b2d4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2690,9 +2690,15 @@ Science Institute} image array manipulation functions.")
                 "01jqqrhcna0ghin48bbcza57d12371ny4l4pqws89irwdhd8xr0r"))))
     (build-system pyproject-build-system)
     (arguments
-     (list #:tests? #f)) ;No tests
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'build-extensions
+            (lambda _
+              ;; Cython extensions have to be built before running the tests.
+              (invoke "python" "setup.py" "build_ext" "--inplace"))))))
     (propagated-inputs (list python-numpy))
-    (native-inputs (list python-setuptools-scm))
+    (native-inputs (list python-pytest python-setuptools-scm))
     (home-page "https://stsciimagestats.readthedocs.io/en/latest/")
     (synopsis "Compute sigma-clipped statistics on data arrays")
     (description