summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-24 22:16:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 23:30:23 +0200
commit180411e3f43ec0eb460a177026a2a80e2c52d111 (patch)
tree240de40c7280177f7b00e382ae8f7b7fb3653e86 /gnu
parent987232e67d9fa77eb1e636e94cb576bf579a0923 (diff)
downloadguix-180411e3f43ec0eb460a177026a2a80e2c52d111.tar.gz
gnu: Add perl-file-configdir.
* gnu/packages/perl.scm (perl-file-configdir): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8f5a5c50b6..859b5fee59 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3116,6 +3116,30 @@ It is really just boilerplate code that you would have written yourself.")
 changes made to any file.")
     (license artistic2.0)))
 
+(define-public perl-file-configdir
+  (package
+    (name "perl-file-configdir")
+    (version "0.018")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RE/REHSACK/"
+                           "File-ConfigDir-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1xpzrlya0gskk7lm6gppyfwbk0swv0n6ssgp629575dk5l49z2rf"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-file-homedir" ,perl-file-homedir)
+       ("perl-list-moreutils" ,perl-list-moreutils)))
+    (home-page "http://search.cpan.org/dist/File-ConfigDir/")
+    (synopsis "Get directories of configuration files")
+    (description "This module is a helper for installing, reading and finding
+configuration file locations.  @code{File::ConfigDir} is a module to help out
+when Perl modules (especially applications) need to read and store
+configuration files from more than one location.")
+    (license (package-license perl))))
+
 (define-public perl-file-copy-recursive
   (package
     (name "perl-file-copy-recursive")