summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:39:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:27 +0200
commit182a4cd1977ad73510a399275e3c4ecbb4add0ec (patch)
tree785197ee07ad98eb8bf34a2a10703dda7a709310 /gnu
parent3d3a745a9e56bc21b0649651d81cffbffa527158 (diff)
downloadguix-182a4cd1977ad73510a399275e3c4ecbb4add0ec.tar.gz
gnu: Add texlive-context-title.
* gnu/packages/tex.scm (texlive-context-title): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 01b68872f5..05abcb5131 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10515,6 +10515,29 @@ presentation.  Most styles are configurable, and it is easy to design
 new styles.")
     (license license:gpl3+)))
 
+(define-public texlive-context-title
+  (package
+    (name "texlive-context-title")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/title/"
+                   "tex/context/interface/third/"
+                   "tex/context/third/title/")
+             (base32
+              "1ah7b5lgqq668s17d5glnl2bwyzh7idsdib4ijxarx7ahph06jx2")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context))
+    (home-page "https://ctan.org/pkg/context-title")
+    (synopsis "Place document titles")
+    (description
+     "The title module provides the @code{\\placetitle} command to put
+a title block into your document.  With the command
+@code{\\setuptitle} values can be set for @code{\\placetitle} and
+change the formatting of the content.")
+    (license license:gpl3+)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")