summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-10-24 22:58:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 23:30:24 +0200
commit189bfb111256dc50d8a04a7b101345fa0d61cd8b (patch)
treee90a36b3d22113ef6c47f223174b054959ed4e74 /gnu
parent544dc8d46bcea6001fb291448e3fa0eac451b83b (diff)
downloadguix-189bfb111256dc50d8a04a7b101345fa0d61cd8b.tar.gz
gnu: Add perl-list-moreutils-xs.
* gnu/packages/perl.scm (perl-list-moreutils-xs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 835a4adb2d..9d054d0b2b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4378,6 +4378,30 @@ intersections, unions, unique elements, complements and many more.")
 functionality on lists which is not going to go into List::Util.")
     (license (package-license perl))))
 
+(define-public perl-list-moreutils-xs
+  (package
+    (name "perl-list-moreutils-xs")
+    (version "0.426")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RE/REHSACK/List-MoreUtils-XS-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0ss0a0f9yqs7gd9qamhaxq27mvn573ljg28ry1gy2pxbz56byzbc"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-config-autoconf" ,perl-config-autoconf)
+       ("perl-inc-latest" ,perl-inc-latest)
+       ("perl-test-leaktrace" ,perl-test-leaktrace)))
+    (home-page "http://search.cpan.org/dist/List-MoreUtils-XS")
+    (synopsis "Provide the stuff missing in List::Util in XS")
+    (description "@code{List::MoreUtils::XS} provides some trivial but
+commonly needed functionality on lists which is not going to go into
+@code{List::Util}.")
+    (license asl2.0)))
+
 (define-public perl-list-someutils
   (package
     (name "perl-list-someutils")