summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 17:57:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:23 +0200
commit191ab5af91391d98e877c3e4894fa65740961ca7 (patch)
tree93829b03aa5cf2cf59231ecc27b3355c089a8df7 /gnu
parent8e79db95672451b9557f1ed267a94749e076556c (diff)
downloadguix-191ab5af91391d98e877c3e4894fa65740961ca7.tar.gz
gnu: Add texlive-armtex.
* gnu/packages/tex.scm (texlive-armtex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 073fd58ca7..b42a96c8b4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1639,6 +1639,36 @@ on indirect resources, such as log file analysis.  Arara requires a Java
 virtual machine.")
     (license license:bsd-3)))
 
+(define-public texlive-armtex
+  (package
+    (name "texlive-armtex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/armenian/"
+                   "fonts/afm/public/armenian/"
+                   "fonts/map/dvips/armenian/"
+                   "fonts/source/public/armenian/"
+                   "fonts/tfm/public/armenian/"
+                   "fonts/type1/public/armenian/"
+                   "tex/latex/armenian/"
+                   "tex/plain/armenian/")
+             (base32
+              "161c66av2zkxp9r32dr449sa9crmyjkjijrvx5a56avkyyr1s0kp")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/armtex")
+    (synopsis "System for writing in Armenian with TeX and LaTeX")
+    (description
+     "ArmTeX is a system for typesetting Armenian text with Plain TeX or LaTeX(2e).
+It may be used with input: from a standard Latin keyboard without any special
+encoding or support for Armenian letters, from any keyboard which uses an
+encoding that has Armenian letters in the second half (characters 128-255) of
+the extended ASCII table (for example ArmSCII8 Armenian standard), or from an
+Armenian keyboard using UTF-8 encoding.")
+    (license license:lppl)))
+
 (define-public texlive-around-the-bend
   (package
     (name "texlive-around-the-bend")