summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2023-12-27 18:51:25 +0100
committerClément Lassieur <clement@lassieur.org>2024-01-12 18:57:45 +0100
commit195c3e109679fa6638e3cd1a0f02529fca9da5b3 (patch)
treeaa2b94d16c20bb0a5efdcc7ad348273e54feb405 /gnu
parent281f899c21973d253edf52eca556e5f9780c08d1 (diff)
downloadguix-195c3e109679fa6638e3cd1a0f02529fca9da5b3.tar.gz
gnu: Add go-github-com-cloudflare-circl.
* gnu/packages/golang.scm (go-github-com-cloudflare-circl): New variable.

Change-Id: Iec8076faa4e14d31311424dbb999fbf8565a49e8
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c6a1cbc8f2..c775d0bfdc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5860,6 +5860,35 @@ Architecture Processors\" by J. Guilford et al.")
       (description "Various cryptographic utilities used by IPFS")
       (license license:expat))))
 
+(define-public go-github-com-cloudflare-circl
+  (package
+    (name "go-github-com-cloudflare-circl")
+    (version "1.3.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cloudflare/circl")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "05hk5svprcjrj6k4mg4kd732pnb658llqv04z6xrcl5v77jda2kd"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/cloudflare/circl"))
+    (propagated-inputs
+     (list go-github-com-bwesterb-go-ristretto
+           go-golang-org-x-crypto
+           go-golang-org-x-sys))
+    (home-page "https://blog.cloudflare.com/introducing-circl")
+    (synopsis "Cloudflare Interoperable Reusable Cryptographic Library")
+    (description "CIRCL (Cloudflare Interoperable, Reusable Cryptographic
+Library) is a collection of cryptographic primitives written in Go.  The goal
+of this library is to be used as a tool for experimental deployment of
+cryptographic algorithms targeting Post-Quantum (PQ) and Elliptic Curve
+Cryptography (ECC).")
+    (license license:bsd-3)))
+
 (define-public go-github-com-mr-tron-base58
   (let ((commit "d724c80ecac7b49e4e562d58b2b4f4ee4ed8c312")
         (revision "0"))