summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-19 13:10:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-19 13:12:29 +0200
commit1baf94dbbe9a8e52a3e745540836acf59d9500a1 (patch)
treed9cd5d3e1eb3f5caad09f1c02c32d8ee893492ce /gnu
parent61d7d9048f148602d8d0dd6dd0724b51eebb3ec6 (diff)
downloadguix-1baf94dbbe9a8e52a3e745540836acf59d9500a1.tar.gz
gnu: java-picard-1.113: Drop trailing #T from build phases.
* gnu/packages/bioinformatics.scm (java-picard-1.113)[arguments]: Remove
trailing #T from build phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 7 insertions, 14 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b2d0f90761..1e7404549b 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5640,8 +5640,7 @@ VCF.")
                '(begin
                   ;; Delete pre-built binaries.
                   (delete-file-recursively "lib")
-                  (mkdir-p "lib")
-                  #t))))
+                  (mkdir-p "lib")))))
     (build-system ant-build-system)
     (arguments
      `(#:build-target "picard-jar"
@@ -5671,8 +5670,7 @@ VCF.")
                (("name=\"test\" depends=\"compile, ")
                 "name=\"test\" depends=\"compile-tests, ")
                (("name=\"compile\" depends=\"compile-src, compile-tests\"")
-                "name=\"compile\" depends=\"compile-src\""))
-             #t))
+                "name=\"compile\" depends=\"compile-src\""))))
          (add-after 'unpack 'fix-deflater-path
            (lambda* (#:key outputs #:allow-other-keys)
              (substitute* "src/java/net/sf/samtools/Defaults.java"
@@ -5680,8 +5678,7 @@ VCF.")
                 (string-append "getStringProperty(\"intel_deflater_so_path\", \""
                                (assoc-ref outputs "out")
                                "/lib/jni/libIntelDeflater.so"
-                               "\")")))
-             #t))
+                               "\")")))))
          ;; Build the deflater library, because we've previously deleted the
          ;; pre-built one.  This can only be built with access to the JDK
          ;; sources.
@@ -5704,25 +5701,21 @@ VCF.")
                        "-c" "-O3" "-fPIC" "IntelDeflater.c")
                (invoke "gcc" "-shared"
                        "-o" "../../../lib/jni/libIntelDeflater.so"
-                       "IntelDeflater.o" "-lz" "-lstdc++"))
-             #t))
+                       "IntelDeflater.o" "-lz" "-lstdc++"))))
          ;; We can only build everything else after building the JNI library.
          (add-after 'build-jni 'build-rest
            (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke `("ant" "all" ,@make-flags))
-             #t))
+             (apply invoke `("ant" "all" ,@make-flags))))
          (add-before 'build 'set-JAVA6_HOME
            (lambda _
-             (setenv "JAVA6_HOME" (getenv "JAVA_HOME"))
-             #t))
+             (setenv "JAVA6_HOME" (getenv "JAVA_HOME"))))
          (replace 'install (install-jars "dist"))
          (add-after 'install 'install-jni-lib
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((jni (string-append (assoc-ref outputs "out")
                                        "/lib/jni")))
                (mkdir-p jni)
-               (install-file "lib/jni/libIntelDeflater.so" jni)
-               #t))))))
+               (install-file "lib/jni/libIntelDeflater.so" jni)))))))
     (inputs
      `(("java-snappy-1" ,java-snappy-1)
        ("java-commons-jexl-2" ,java-commons-jexl-2)