summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 20:47:48 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:17 +0100
commit1d7bf223c874977b81c376cda70892163e580072 (patch)
treea6a6e1f5a331c62be124f76460b1727e51b0f35c /gnu
parentc006f68fdb356835c46ed236769581925f753031 (diff)
downloadguix-1d7bf223c874977b81c376cda70892163e580072.tar.gz
gnu: python-dyniterpy: Add missing inputs.
* gnu/packages/finance.scm (python-duniterpy)[arguments]: Add
loosen-requirements phase.
[propagated-inputs]: Add PYTHON-GRAPHQL-CORE, PYTHON-MNEMONIC, and
PYTHON-WEBSOCKET-CLIENT.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 73ffb7ea7c..0d6a0515c4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1250,7 +1250,13 @@ Luhn and family of ISO/IEC 7064 check digit algorithms.")
     (arguments
      ;; FIXME: Tests fail with: "TypeError: block_uid() missing 1 required
      ;; positional argument: 'value'".
-     `(#:tests? #f))
+     `(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'loosen-requirements
+                    (lambda _
+                      (substitute* "setup.py"
+                        (("mnemonic>=0\\.19,<0.20")
+                         "mnemonic>=0.19")))))))
     (propagated-inputs
      `(("aiohttp" ,python-aiohttp)
        ("attrs" ,python-attrs)
@@ -1259,6 +1265,9 @@ Luhn and family of ISO/IEC 7064 check digit algorithms.")
        ("libnacl" ,python-libnacl)
        ("pyaes" ,python-pyaes)
        ("pylibscrypt" ,python-pylibscrypt)
+       ("python-graphql-core" ,python-graphql-core)
+       ("python-mnemonic" ,python-mnemonic)
+       ("python-websocket-client" ,python-websocket-client)
        ("pypeg2" ,python-pypeg2)))
     (home-page "https://git.duniter.org/clients/python/duniterpy")
     (synopsis "Python implementation of Duniter API")