summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-06 11:24:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:33 +0100
commit1d9169847886985f2b45fddc458d92244f311a68 (patch)
tree54c8ae291242a4012450c0e6f4c80482d3668513 /gnu
parentce451cdcb8f36ca48d4fe70f2235f406a86ed7b8 (diff)
downloadguix-1d9169847886985f2b45fddc458d92244f311a68.tar.gz
gnu: Add pybind11-2.10.
* gnu/packages/python-xyz.scm (pybind11-2.10): New variable.

Change-Id: Ia7915af3baca36b0677d3f762046585abc473f56
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3000caa5ff..b29dd2a386 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25802,6 +25802,22 @@ library: to minimize boilerplate code in traditional extension modules by
 inferring type information using compile-time introspection.")
     (license license:bsd-3)))
 
+;; Needed for scipy
+(define-public pybind11-2.10
+  (package
+    (inherit pybind11)
+    (name "pybind11")
+    (version "2.10.4")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pybind/pybind11")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "0rbcfvl7y472sykzdq3vrkw83kar0lpzhk3wq9yj9cdydl8cpfcz"))
+              (file-name (git-file-name name version))))))
+
 ;; This is needed for python-vaex-core.
 (define-public pybind11-2.3
   (package