summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-28 09:45:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-28 16:05:56 +0200
commit1ec17821069601cbc45b31b4d80973c0a8947f35 (patch)
tree9ebf4516897a6272a70bc00f7da97a03df30b2fd /gnu
parent70554077704742fd458ec8253299fcc2b0541925 (diff)
downloadguix-1ec17821069601cbc45b31b4d80973c0a8947f35.tar.gz
gnu: make-blis: Always return #T from configure phase.
* gnu/packages/maths.scm (make-blis)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 201fb9c970..e4e9c52598 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3087,13 +3087,13 @@ underway to allow BLIS to select the right optimized kernels at run time:
                     (lambda* (#:key outputs #:allow-other-keys)
                       ;; This is a home-made 'configure' script.
                       (let ((out (assoc-ref outputs "out")))
-                        (zero? (system* "./configure" "-p" out
-                                        "-d" "opt"
-                                        "--disable-static"
-                                        "--enable-shared"
-                                        "--enable-threading=openmp"
+                        (invoke "./configure" "-p" out
+                                "-d" "opt"
+                                "--disable-static"
+                                "--enable-shared"
+                                "--enable-threading=openmp"
 
-                                        ,implementation)))))
+                                ,implementation))))
                   (add-before 'check 'show-test-output
                     (lambda _
                       ;; By default "make check" is silent.  Make it verbose.