summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-07-31 19:05:08 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-08-02 15:22:27 +0200
commit1f10e28d86a9f3b85103034aed104c0ac9a4ce85 (patch)
treefd0f8c34a6a07b5ab7940d3a283cddc2a64b714b /gnu
parentc106d03b88a9142554868ad597f488566a250c53 (diff)
downloadguix-1f10e28d86a9f3b85103034aed104c0ac9a4ce85.tar.gz
gnu: Add ruby-childprocess@0.6.3.
* gnu/packages/ruby.scm (ruby-childprocess): Modify.
(ruby-childprocess-0.6): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index aa4cae6f97..4739579bfd 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5033,17 +5033,17 @@ in standard Ruby syntax.")
     (home-page "https://github.com/ruby/rake")
     (license license:expat)))
 
-(define-public ruby-childprocess
+(define-public ruby-childprocess-0.6
   (package
     (name "ruby-childprocess")
-    (version "0.9.0")
+    (version "0.6.3")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "childprocess" version))
        (sha256
         (base32
-         "0a61922kmvcxyj5l70fycapr87gz1dzzlkfpq85rfqk5vdh3d28p"))))
+         "1p3f43scdzx9zxmy2kw5zsc3az6v46nq4brwcxmnscjy4w4racbv"))))
     (build-system ruby-build-system)
     (arguments
      `(#:tests? #f))
@@ -5057,3 +5057,16 @@ in standard Ruby syntax.")
 programs running in the background, in Ruby.")
     (home-page "http://github.com/enkessler/childprocess")
     (license license:expat)))
+
+(define-public ruby-childprocess
+  (package
+    (inherit ruby-childprocess-0.6)
+    (name "ruby-childprocess")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "childprocess" version))
+       (sha256
+        (base32
+         "0a61922kmvcxyj5l70fycapr87gz1dzzlkfpq85rfqk5vdh3d28p"))))))