summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-02-09 20:48:33 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-02-09 22:54:58 +0100
commit1f42d824c1fb3790da93ef2596776e23dc57c0c9 (patch)
tree13a872478b293702d473c6fdeff692a686a3a900 /gnu
parent1a917fc9de503d0d8b436c5c1467a34d29427178 (diff)
downloadguix-1f42d824c1fb3790da93ef2596776e23dc57c0c9.tar.gz
gnu: Add python-flake8-polyfill.
* gnu/packages/python.scm (python-flake8-polyfill, python2-flake8-polyfill):
New variables.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a8bf99b8fe..da6deb51c2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5993,6 +5993,28 @@ complexity of Python source code.")
 (define-public python2-flake8-2.2.4
   (package-with-python2 python-flake8-2.2.4))
 
+(define-public python-flake8-polyfill
+  (package
+    (name "python-flake8-polyfill")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flake8-polyfill" version))
+       (sha256
+        (base32
+         "02gn2wxvh9vnf7m7dld7ca4l60mg5c370hv3swwppkngwaqmcw67"))))
+    (build-system python-build-system)
+    (home-page "https://gitlab.com/pycqa/flake8-polyfill")
+    (synopsis "Polyfill package for Flake8 plugins")
+    (description
+     "This package that provides some compatibility helpers for Flake8
+plugins that intend to support Flake8 2.x and 3.x simultaneously.")
+    (license license:expat)))
+
+(define-public python2-flake8-polyfill
+  (package-with-python2 python-flake8-polyfill))
+
 (define-public python-mistune
   (package
     (name "python-mistune")