summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 18:56:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 18:56:29 +0100
commit1f5c1bc024874b697e4251e1410919b705a86eb3 (patch)
treebbbeaf389d2c9ccca928768191c008f61c361545 /gnu
parenta2423c0ca479e855ee135cd59bd9e3ab647ec51e (diff)
downloadguix-1f5c1bc024874b697e4251e1410919b705a86eb3.tar.gz
gnu: python2-decorator: Downgrade to 4.3.0
* gnu/packages/python-xyz.scm (python2-decorator): Keep at 4.3.0.
(python-decorator)[properties]: Add python2-variant.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 18a9b775e7..c607aff3d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7633,10 +7633,21 @@ PNG, PostScript, PDF, and SVG file output.")
 for the average programmer, and to popularize decorators usage giving examples
 of useful decorators, such as memoize, tracing, redirecting_stdout, locked,
 etc.  The core of this module is a decorator factory.")
-    (license license:expat)))
+    (license license:expat)
+    (properties `((python2-variant . ,(delay python2-decorator))))))
 
+;; Version 5 does not support Python 2
 (define-public python2-decorator
-  (package-with-python2 python-decorator))
+  (package
+    (inherit (package-with-python2
+              (strip-python2-variant python-decorator)))
+    (version "4.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "decorator" version))
+       (sha256
+        (base32 "0308djallnh00v112y5b7nadl657ysmkp6vc8xn51d6yzc9zm7n3"))))))
 
 (define-public python-drmaa
   (package