summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 15:09:55 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 15:29:22 +0200
commit1f80d41735612f40ae53c6964c0bc707f1200bbb (patch)
treea90cbff7505343e94eec6348f08b44f1cd8ec785 /gnu
parent15b35874b104723c5f1bf39a92469c43e514350f (diff)
downloadguix-1f80d41735612f40ae53c6964c0bc707f1200bbb.tar.gz
gnu: Add r-nebulosa.
* gnu/packages/bioconductor.scm (r-nebulosa): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 17ad509197..bf989a8220 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5335,6 +5335,37 @@ pre-calculated probe set quality scores that were used to define the
 mapping.")
     (license license:artistic2.0)))
 
+(define-public r-nebulosa
+  (package
+    (name "r-nebulosa")
+    (version "1.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "Nebulosa" version))
+              (sha256
+               (base32
+                "0lqm9mfmaxdhhs9di2kjg2rixng78lrrikyp7blmpyqk4c41j3nh"))))
+    (properties `((upstream-name . "Nebulosa")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ggplot2
+                             r-ks
+                             r-matrix
+                             r-patchwork
+                             r-seurat
+                             r-singlecellexperiment
+                             r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/powellgenomicslab/Nebulosa")
+    (synopsis
+     "Single-cell data visualisation using kernel gene-weighted density estimation")
+    (description
+     "This package provides a enhanced visualization of single-cell data based
+on gene-weighted density estimation.  Nebulosa recovers the signal from
+dropped-out features and allows the inspection of the joint expression from
+multiple features (e.g. genes).  @code{Seurat} and @code{SingleCellExperiment}
+objects can be used within Nebulosa.")
+    (license license:gpl3)))
+
 ;; This is a CRAN package, but it depends on Bioconductor packages.
 (define-public r-nmf
   (package