summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-12-14 13:06:45 -0500
committerLudovic Courtès <ludo@gnu.org>2020-12-21 17:47:36 +0100
commit1fd317de920491102328ed7b38579633b2a2901e (patch)
treeb0f597effdaf2cda8971b20d3574bd61a9414dee /gnu
parentc626e281b4c7b522da6962bc045fe6372b18ac10 (diff)
downloadguix-1fd317de920491102328ed7b38579633b2a2901e.tar.gz
gnu: sdcc: Specify complete set of licenses.
* gnu/packages/embedded.scm (sdcc)[license]: Replace with full list of
licenses used by files in the distribution.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/embedded.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 2d822cecf3..545c512f18 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1511,4 +1511,10 @@ HC08-based (hc08, s08), Zilog Z80-based MCUs (z80, z180, gbz80, Rabbit
 2000/3000, Rabbit 3000A, TLCS-90) and STMicroelectronics STM8.
 Work is in progress on supporting the Microchip PIC16 and PIC18 targets.
 It can be retargeted for other microprocessors.")
-    (license license:gpl2+)))
+    (license (list license:gpl2+
+                   license:gpl3+
+                   license:lgpl2.0+
+                   license:lgpl2.1+
+                   license:lgpl3+
+                   license:public-domain
+                   license:zlib))))