summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-01-10 08:38:32 +0100
committerRutger Helling <rhelling@mykolab.com>2019-01-10 08:41:03 +0100
commit20b4aa6babde823b577f58546fae5ba5297d3ea4 (patch)
treeb856f0002ac402d4c7102c9a3497300071bed4ba /gnu
parent1f61cc102e205dc1cda8f1ea4bc10dd82b1864e9 (diff)
downloadguix-20b4aa6babde823b577f58546fae5ba5297d3ea4.tar.gz
gnu: Add wlstream.
* gnu/packages/video.scm (wlstream): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 15e28d89f3..cddb714024 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3269,3 +3269,32 @@ transitions, and effects and then export your film to many common formats.")
     (description "dav1d is a new AV1 cross-platform decoder, and focused on
 speed and correctness.")
     (license license:bsd-2)))
+
+(define-public wlstream
+  (let ((commit "182076a94562b128c3a97ecc53cc68905ea86838")
+        (revision "1"))
+    (package
+      (name "wlstream")
+      (version (git-version "0.0" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                (url "https://github.com/atomnuker/wlstream.git")
+                (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32
+            "01qbcgfl3g9kfwn1jf1z9pdj3bvf5lmg71d1vwkcllc2az24bjqp"))))
+      (build-system meson-build-system)
+      (native-inputs `(("libdrm" ,libdrm)
+                       ("pkg-config" ,pkg-config)))
+      (inputs `(("ffmpeg" ,ffmpeg)
+                ("pulseaudio" ,pulseaudio)
+                ("wayland" ,wayland)
+                ("wayland-protocols" ,wayland-protocols)))
+      (home-page "https://github.com/atomnuker/wlstream")
+      (synopsis "Screen capture tool for Wayland sessions")
+      (description "Wlstream is a screen capture tool for recording audio and
+video from a Wayland session.")
+      (license license:lgpl2.1+))))