summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-12-04 03:32:30 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-05 11:03:14 +0100
commit2149515808175b8dc9000ea40c92e9c5240e5a67 (patch)
treef443ce86db50b5b0cb111334c6b399c6a7eaca48 /gnu
parente70e26423bffa080580a66d61cdd2158525e7f3f (diff)
downloadguix-2149515808175b8dc9000ea40c92e9c5240e5a67.tar.gz
gnu: Add leo.
* gnu/packages/web-browsers.scm (leo): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web-browsers.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index db387f1b35..af142796e8 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -927,6 +927,32 @@ interface.")
     (description "Telescope is a w3m-like browser for Gemini.")
     (license license:x11)))
 
+(define-public leo
+  ;; PyPi only provides a wheel.
+  (let ((commit "88cc10a87afe2ec86be06e6ea2bcd099f5360b74")
+        (revision "1"))
+    (package
+      (name "leo")
+      (version (string-append "1.0.4-" revision "." (string-take commit 9)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/xyzshantaram/leo")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0jp4v4jw82qqynqqs7x35g5yvm1sd48cvbqh7j2r1ixw1z6ldhc4"))))
+      (build-system python-build-system)
+      (home-page "https://github.com/xyzshantaram/leo")
+      (synopsis "Gemini client written in Python")
+      (description
+"@command{leo} is a gemini client written in Python with no external
+dependencies that fully implements the Gemini spec.  A list of URLs can
+be saved to a file for further viewing in another window.")
+      (license license:expat))))
+
 (define-public av-98
   (package
     (name "av-98")