summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGruruya <greytest@disroot.org>2023-03-25 08:30:28 -0400
committerEfraim Flashner <efraim@flashner.co.il>2023-06-06 19:24:47 +0300
commit2199546a83e521fe3dd78a3014f7ff7b88400191 (patch)
treeae4f7e345322f04a91c776161731e9d42fd80e40 /gnu
parent1a2eb26286c72ac2754969f53f5833b053b96b67 (diff)
downloadguix-2199546a83e521fe3dd78a3014f7ff7b88400191.tar.gz
gnu: nim: Update to 1.6.12.
Without the attached patch, Nim is broken on Guix as it searches
for its stdlib in /lib while it was placed in /lib/nim.

* gnu/packages/nim.scm (nim): Update to 1.6.12.
[arguments]: In 'patch-installer phase install stdlib source to the
right directory.  In 'patch-more-shebangs phase edit substitute* to
point to the new osproc source.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/nim.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index 6da382119f..ebcff26c7b 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
 ;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
+;;; Copyright © 2023 Gruruya <greytest@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,14 +37,14 @@
 (define-public nim
   (package
     (name "nim")
-    (version "1.6.6")
+    (version "1.6.12")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "https://nim-lang.org/download/"
                           name "-" version ".tar.xz"))
       (sha256
-       (base32 "0lm4450ig8k4l3rzxv6kcqji5l1lzicsw76ckwxm0q9qdz713cb7"))))
+       (base32 "1hjd9dxhqzn2ifr988li8q7v6kxpxlcqbdllfd6lsq3knw50pvxc"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f          ; TODO: Investigate tests failures.
@@ -55,6 +56,7 @@
                (let ((out (assoc-ref outputs "out")))
                  (substitute* "install.sh"
                   (("/usr/local") out)
+                  (("/lib/nim") "/lib")
                   (("/opt/nimble") (string-append out "/share/nimble"))
                   (("configdir=/etc/nim")
                    (string-append "configdir=" out "/etc/nim"))))))
@@ -102,7 +104,7 @@
                                 "lib/pure/osproc.nim"
                                 "lib/pure/strscans.nim")
                    (("/bin/sh") sh))
-                 (substitute* (find-files "c_code" "stdlib_osproc\\.nim\\.c")
+                 (substitute* (find-files "c_code" "@m\\.\\.@slib@spure@sosproc\\.nim\\.c")
                    (("\"/bin/sh\", 7") (format #f "~s, ~s" sh (string-length sh)))))))
            (replace 'build
              (lambda* (#:key (parallel-build? #t) #:allow-other-keys)