summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-05-17 00:27:44 +0200
committerBen Woodcroft <donttrustben@gmail.com>2017-05-17 00:28:56 +0200
commit21aecec1a94f88df9cc3b43ece582a4050cb5e7a (patch)
tree35ad6940dd6aa6acc51c672c450f6d54b19f7d6b /gnu
parent473f34cbdce388d6dfd01ea472ec6ade2a187811 (diff)
downloadguix-21aecec1a94f88df9cc3b43ece582a4050cb5e7a.tar.gz
gnu: ruby-concurrent: Update to 1.0.5.
* gnu/packages/ruby.scm (ruby-concurrent): Update to 1.0.5.
* gnu/packages/patches/ruby-concurrent-test-arm.patch: Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/ruby-concurrent-test-arm.patch26
-rw-r--r--gnu/packages/ruby.scm4
2 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/patches/ruby-concurrent-test-arm.patch b/gnu/packages/patches/ruby-concurrent-test-arm.patch
index 75e6365565..06d5657814 100644
--- a/gnu/packages/patches/ruby-concurrent-test-arm.patch
+++ b/gnu/packages/patches/ruby-concurrent-test-arm.patch
@@ -5,27 +5,27 @@ Work around two test suite failures on ARM:
 The regexps here assume addresses like "0x1234" but on ARM (32-bit)
 we get something like "0x-7db1e810" (notice the dash).
 
-diff --git a/spec/concurrent/edge/future_spec.rb b/spec/concurrent/edge/future_spec.rb
-index a48fd29..4344d7e 100644
---- b/spec/concurrent/edge/future_spec.rb
-+++ a/spec/concurrent/edge/future_spec.rb
-@@ -322,9 +322,9 @@
+diff --git a/spec/concurrent/edge/promises_spec.rb b/spec/concurrent/edge/promises_spec.rb
+index 727210f..149f7cd 100644
+--- a/spec/concurrent/edge/promises_spec.rb
++++ b/spec/concurrent/edge/promises_spec.rb
+@@ -371,9 +371,9 @@ describe 'Concurrent::Promises' do
        four  = three.delay.then(&:succ)
  
        # meaningful to_s and inspect defined for Future and Promise
--      expect(head.to_s).to match /<#Concurrent::Edge::Future:0x[\da-f]+ pending>/
-+      expect(head.to_s).to match /<#Concurrent::Edge::Future:0x-?[\da-f]+ pending>/
+-      expect(head.to_s).to match /<#Concurrent::Promises::Future:0x[\da-f]+ pending>/
++      expect(head.to_s).to match /<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/
        expect(head.inspect).to(
--          match(/<#Concurrent::Edge::Future:0x[\da-f]+ pending blocks:\[<#Concurrent::Edge::ThenPromise:0x[\da-f]+ pending>\]>/))
-+          match(/<#Concurrent::Edge::Future:0x-?[\da-f]+ pending blocks:\[<#Concurrent::Edge::ThenPromise:0x-?[\da-f]+ pending>\]>/))
+-          match(/<#Concurrent::Promises::Future:0x[\da-f]+ pending>/))
++          match(/<#Concurrent::Promises::Future:0x-?[\da-f]+ pending>/))
  
        # evaluates only up to three, four is left unevaluated
        expect(three.value!).to eq 3
 diff --git a/spec/concurrent/map_spec.rb b/spec/concurrent/map_spec.rb
-index 13fd5b7..1c82ebe 100644
---- b/spec/concurrent/map_spec.rb
-+++ a/spec/concurrent/map_spec.rb
-@@ -827,7 +827,7 @@
+index c4050be..0a9095d 100644
+--- a/spec/concurrent/map_spec.rb
++++ b/spec/concurrent/map_spec.rb
+@@ -794,7 +794,7 @@ module Concurrent
      end
  
      it '#inspect' do
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9cb8ab46af..747b1813ab 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -4107,7 +4107,7 @@ call.")
 (define-public ruby-concurrent
   (package
     (name "ruby-concurrent")
-    (version "1.0.2")
+    (version "1.0.5")
     (source
      (origin
        (method url-fetch)
@@ -4120,7 +4120,7 @@ call.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "1x3g2admp14ykwfxidsicqbhlfsnxh9wyc806np4i15hws4if1d8"))
+         "0qhv0qzsby4iijgwa4s9r88zj8123pmyz1dwaqzdk57xgqll9pny"))
        ;; Exclude failing test reported at
        ;; https://github.com/ruby-concurrency/concurrent-ruby/issues/534
        (patches (search-patches "ruby-concurrent-ignore-broken-test.patch"