summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-05-06 21:29:09 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2021-05-06 21:29:29 +0200
commit22796f1ad16abb7b1519d11332175d147ae10b82 (patch)
tree60c7c9ffa95b7dcd67314316fb0758149586bbbf /gnu
parentdd52cb9725bd527b7d831903734b09185837b01b (diff)
downloadguix-22796f1ad16abb7b1519d11332175d147ae10b82.tar.gz
gnu: Add pathname-utils.
* gnu/packages/lisp-xyz.scm (cl-pathname-utils, ecl-pathname-utils,
sbcl-pathname-utils): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index cf6315ae90..a00c272a43 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -16368,3 +16368,35 @@ for Common Lisp.")
 
 (define-public cl-bknr-datastore
   (sbcl-package->cl-source-package sbcl-bknr-datastore))
+
+(define-public sbcl-pathname-utils
+  ;; No new release in years.
+  (let ((commit "4ebc0fe97b7e299ba93cc9c50938445eef77e352"))
+    (package
+      (name "sbcl-pathname-utils")
+      (version (git-version "1.1.0" "1" commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/pathname-utils")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0zjv39lrqdq96m4cypig33fh3iw5l7ivm3lwvzh08h70jswda0y4"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs
+       `(("parachute" ,sbcl-parachute)))
+      (home-page "https://github.com/privet-kitty/dufy")
+      (synopsis "Pathname manipulation library for Common Lisp")
+      (description
+       "This is a Common Lisp collection of common tests and operations to
+help handling pathnames.  It does not actually deal in handling the accessing
+of files on the underlying system however.")
+      (license license:zlib))))
+
+(define-public ecl-pathname-utils
+  (sbcl-package->ecl-package sbcl-pathname-utils))
+
+(define-public cl-pathname-utils
+  (sbcl-package->cl-source-package sbcl-pathname-utils))