summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-03 14:36:05 +0200
committerRoel Janssen <roel@gnu.org>2018-04-03 14:36:05 +0200
commit229241b1a47bcd5c366fdefab2dcbe233496d5d6 (patch)
treecbdd708ac195c12ad04eb146b0ce5faee05e7d53 /gnu
parent9b3deccd60b4ad896632e15978f6b9bf59399483 (diff)
downloadguix-229241b1a47bcd5c366fdefab2dcbe233496d5d6.tar.gz
gnu: Add perl-inline.
* gnu/packages/perl.scm (perl-inline): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 022cd7e884..041db7a470 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3975,6 +3975,30 @@ inc directory within a distribution and are used by Makefile.PL or Build.PL.")
      "Indirect warns about using the indirect method call syntax.")
     (license (package-license perl))))
 
+(define-public perl-inline
+  (package
+   (name "perl-inline")
+   (version "0.80")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "mirror://cpan/authors/id/I/IN/INGY/Inline-"
+           version ".tar.gz"))
+     (sha256
+      (base32
+       "1xnf5hykcr54271x5jsnr61bcv1c7x39cy4kdcrkxm7bn62djavy"))))
+   (build-system perl-build-system)
+   (native-inputs
+    `(("perl-test-warn" ,perl-test-warn)))
+   (home-page "http://search.cpan.org/dist/Inline/")
+   (synopsis "Write Perl subroutines in other programming languages")
+   (description "The @code{Inline} module allows you to put source code
+from other programming languages directly (inline) in a Perl script or
+module.  The code is automatically compiled as needed, and then loaded
+for immediate access from Perl.")
+   (license (package-license perl))))
+
 (define-public perl-io-captureoutput
   (package
     (name "perl-io-captureoutput")