summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2015-08-17 08:26:07 +0200
committerMark H Weaver <mhw@netris.org>2015-08-24 11:40:41 -0400
commit22d0e9b79255dce67e6986e7529ccb0f843b102d (patch)
tree7c44307c3688e8bdfcf25e0bf78858ae23cbf5f3 /gnu
parentc34507d662979a69a0d0738d64e21d4866931b88 (diff)
downloadguix-22d0e9b79255dce67e6986e7529ccb0f843b102d.tar.gz
gnu: Simplify LLVM build.
* gnu/packages/llvm.scm (llvm)[arguments]: Remove phases argument.
  Add to configure-flags "-DCMAKE_SKIP_BUILD_RPATH=FALSE" and
  "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm20
1 files changed, 2 insertions, 18 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 9e06a64092..2c96e9d638 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -49,24 +49,8 @@
      `(("python" ,python-wrapper)
        ("perl"   ,perl)))
     (arguments
-     `(#:phases (alist-cons-before
-                 'build 'link-lib-for-build-exec
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   ;; This is a hacky fix that will allow binaries to run
-                   ;; before being installed.  -DCMAKE_SKIP_BUILD_RPATH=FALSE
-                   ;; seems to not help.  Nixpkgs does the same.
-                   (let* ((out       (assoc-ref outputs "out"))
-                          (out-lib   (string-append out "/lib"))
-                          (build-lib (string-append (getcwd) "/lib")))
-                     (mkdir-p out)
-                     (symlink build-lib out-lib)))
-                 (alist-cons-after
-                  'build 'cleanup-out
-                  (lambda* (#:key outputs #:allow-other-keys)
-                    ;; Cleanup the symlink that was created previously.  Let
-                    ;; the install phase repopulate out.
-                    (delete-file-recursively (assoc-ref outputs "out")))
-                  %standard-phases))))
+     `(#:configure-flags '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
+                           "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE")))
     (home-page "http://www.llvm.org")
     (synopsis "Optimizing compiler infrastructure")
     (description