summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:08 +0200
commit236edb05d7aee0e88127a3809ff77786f934aec6 (patch)
treee1769da124469809d61ff950d8d9daaaa9d31269 /gnu
parent0dafac1cfbdffca8b0f655d85356409fed5bacdf (diff)
downloadguix-236edb05d7aee0e88127a3809ff77786f934aec6.tar.gz
gnu: nvme-cli: Separate :doc files.
* gnu/packages/linux.scm (nvme-cli)[outputs]: Add "doc".
[arguments]: Install HTML documentation there.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 31e1e78355..221293f5aa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5175,10 +5175,11 @@ and manage nvme devices on a Linux system.")
                (base32 "1jv1xir6gm86yyk5846qqkcjhc1bq103zyxf794fznyinh4nhlbg"))
               (file-name (git-file-name name version))))
     (build-system meson-build-system)
+    (outputs (list "out" "doc"))        ; docs make up ~70% of total size
     (arguments
      (list
       #:configure-flags #~(list (format #f "-Dhtmldir=~a/share/doc/~a/html"
-                                        #$output #$name)
+                                        #$output:doc #$name)
                                 "-Ddocs=all")))
     (native-inputs (list pkg-config))
     (inputs (list libnvme json-c zlib))