summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-02-13 21:33:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-02-13 21:48:12 +0200
commit2385012b894a07701e167e0d7347b40e8383c1d2 (patch)
tree7a3da3f5cefe42a066401fbe6584792dddb85903 /gnu
parent2de52d0cbb1812ff05e9939bc2fec61946ec41a0 (diff)
downloadguix-2385012b894a07701e167e0d7347b40e8383c1d2.tar.gz
gnu: khard: Enable tests.
* gnu/packages/mail.scm (khard)[arguments]: Enable test suite.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 4b91f0230f..982a75c7e2 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1739,18 +1739,14 @@ maintained.")
                 "1lyjiskc6ckjjylzr04dnm66p3cnn7vlysw9c27qls3y3ywx14zw"))))
     (build-system python-build-system)
     (arguments
-      `(#:phases
-        (modify-phases %standard-phases
-          (add-after 'install 'install-doc
-            (lambda* (#:key outputs #:allow-other-keys)
-              (let* ((out (assoc-ref outputs "out"))
-                     (doc (string-append out "/share/doc/khard")))
-                (copy-recursively "misc/khard" doc)
-                #t))))
-        ;; Tests are currently only runnable without preexisting data on
-        ;; the development branch:
-        ;; https://github.com/scheibler/khard/issues/176
-        #:tests? #f))
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (string-append out "/share/doc/khard")))
+               (copy-recursively "misc/khard" doc)
+               #t))))))
     (propagated-inputs
      `(("python-atomicwrites" ,python-atomicwrites)
        ("python-configobj" ,python-configobj)