summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-01 16:35:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-18 11:35:47 +0300
commit238d398451577837dcfe8a5f73dee937ac28a1d5 (patch)
tree46d301aaebe85071d12d1d4f00efec15237499c9 /gnu
parent751c4249d11aaa676c189fab7733a7993ee66b54 (diff)
downloadguix-238d398451577837dcfe8a5f73dee937ac28a1d5.tar.gz
gnu: Add rust-paste-test-suite-0.0.0.
* gnu/packages/crates-io.scm (rust-paste-test-suite-0.0.0): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index afcc4bfc2c..fe82ac5c4f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46580,6 +46580,24 @@ Format (MCF).")
      "Implementation detail of the paste crate.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-paste-test-suite-0.0.0
+  (package
+    (name "rust-paste-test-suite")
+    (version "0.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "paste-test-suite" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0mllghv41sz978ymxym8nm6yh1qljshsbjk6iaycbk6zlw7gqagh"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t)) ; Not meant to be used individually.
+    (home-page "https://github.com/dtolnay/paste")
+    (synopsis "Test suite of the paste crate")
+    (description "Test suite of the paste crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-path-abs-0.5
   (package
     (name "rust-path-abs")