summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-11 17:24:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-11 17:24:34 -0400
commit245ddc255a51c576ddad8fab6222cde1c3da21ab (patch)
treec6a43e35ebee1bb1464e24a327c144a95aeed7a7 /gnu
parent7476a910a1c044583a2cb50037761c294761f1ad (diff)
downloadguix-245ddc255a51c576ddad8fab6222cde1c3da21ab.tar.gz
gnu: git: Install Info manual.
Partially fixes <https://issues.guix.gnu.org/55821>.

* gnu/packages/version-control.scm (git)[native-inputs]: Add docbook2x,
libxslt and texinfo.
[phases]{install-info-manual}: New phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 67fec6ff46..4202d3fd3e 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -251,9 +251,12 @@ Python 3.3 and later, rather than on Python 2.")
             "0vsfjs6xg228yhqcpaiwkpncaqcghnm0pwdxmgibz0rj6d8ydrmi"))))
       ;; For subtree documentation.
       ("asciidoc" ,asciidoc)
+      ("docbook2x" ,docbook2x)
       ("docbook-xsl" ,docbook-xsl)
-      ("xmlto" ,xmlto)
-      ("pkg-config" ,pkg-config)))
+      ("libxslt" ,libxslt)
+      ("pkg-config" ,pkg-config)
+      ("texinfo" ,texinfo)
+      ("xmlto" ,xmlto)))
    (inputs
     `(("curl" ,curl)
       ("expat" ,expat)
@@ -430,6 +433,16 @@ Python 3.3 and later, rather than on Python 2.")
                           "t/t9167-git-svn-cmd-branch-subproject.sh"
                           "t/t9141-git-svn-multiple-branches.sh"))
               #t)))
+        (add-after 'install 'install-info-manual
+          (lambda* (#:key parallel-build? #:allow-other-keys)
+            (define job-count (if parallel-build?
+                                  (number->string (parallel-job-count))
+                                  "1"))
+            (invoke "make" "-C" "Documentation" "install-info"
+                    "-j" job-count
+                    ;; The Makefile refer to 'docbook2x-texi', but our binary
+                    ;; is named 'docbook2texi'.
+                    "DOCBOOK2X_TEXI=docbook2texi" "PERL_PATH=perl")))
         (add-after 'install 'install-shell-completion
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out         (assoc-ref outputs "out"))